Degraded Image Processing due to AWS Incident
Incident Report for AuctionMethod
Resolved
This incident has been resolved.
Posted Sep 29, 2022 - 10:19 EDT
Monitoring
According to AWS, the affected service has been restored to normal operation.
Please resume uploading images and syncing items from the cataloging app.
Please report any issues with image processing to support@auctionmethod.com.

From AWS:
[02:05 PM PDT] As of 1:43 PM PDT, error rates and latencies for invoked on API Gateway endpoints in the US-WEST-2 Region are now at normal levels. The issue began at 9:20 AM PDT when error rates and latencies for API Gateway began to increase. Error rates began to improve at 10:38 AM PDT, when engineers took action to reduce contention within the subsystem that handles request processing for API Gateway. Error rates continued to improve until 1:10 PM PDT, when engineers applied a mitigation to resolve the contention within the affected subsystem. These actions accelerated recovery, and by 1:43 PM PDT, error rates and latencies had returned to normal levels. Affected AWS services have now recovered as well. The issue has been resolved and the service is operating normally.
Posted Sep 28, 2022 - 17:08 EDT
Update
There continue to be issues with uploading images to the site - both directly on the site and via the cataloging app.
AuctionMethod recommends that you wait until this issue is fully resolved before attempting to upload images to avoid image loss.

FROM AWS:
We continue to see an improvement in error rates and latencies for invokes on API Gateway endpoints in the US-WEST-2 Region, but have not fully resolved the issue. While our mitigations have improved error rates and latencies, we have also identified the root cause of the event. The subsystem responsible for request processing experienced increased load, which ultimately led to contention of a component within the affected subsystem. Engineers have been working to resolve the contention of the affected component, which has led to a reduction of error rates and latencies. The path to full recovery involves addressing the contention across the subsystem, which we are currently doing. As that progresses over the next two hours, we expect recovery to continue to improve. Customers with applications that use API Gateway will be experiencing elevated error rates and latencies as a result of this issue. Lambda is not affected by this event, but customers using API Gateway as an HTTP endpoint for Lambda will experience increased error rates and latencies. Other AWS services listed below are also experiencing elevated error rates as a result of this issue. For customers that have dependencies on API Gateway and are experiencing error rates, we do not have any mitigations to recommend to address the issue on the customer side. We do expect error rates to continue to improve as contention with the affected subsystem resides, and will provide further updates as recovery progresses.
Posted Sep 28, 2022 - 15:41 EDT
Update
There are ongoing issues with uploading images to the site - both directly on the site and via the cataloging app. AuctionMethod recommends that you wait until this issue is fully resolved before attempting to upload images to avoid image loss.

FROM AWS:
We continue to work on resolving the elevated error rates and latencies for invokes on API Gateway endpoints in the US-WEST-2 Region. We continue to see a significant improvement in error rates, starting at 10:40 AM PDT, but are not seeing full recovery yet. The issue is caused by contention within the subsystem that is responsible for request processing within the API Gateway service. Engineers are engaged and have applied traffic filters as a precautionary measure, while they work to identify the root cause and resolve the issue. Engineers continue to work to reduce contention within the affected subsystem, which we believe will resolve the elevated error rates and latencies. Customers with applications that use API Gateway, or customers invoking Lambda functions via API Gateway, will be experiencing elevated error rates and latencies as a result of this issue. The AWS services listed below are also experiencing elevated error rates as a result of this issue. While we have seen improvements in error rates since 10:40 AM PDT, recovery has stalled and we do not have a clear ETA on full recovery. For customers that have dependencies on API Gateway and are experiencing error rates, we do not have any mitigations to recommend to address the issue on the customer side. We do expect error rates to continue to improve as contention with the affected subsystem resides, and will provide further updates as recovery progresses.
Posted Sep 28, 2022 - 15:27 EDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 28, 2022 - 15:26 EDT
Identified
There are ongoing issues with uploading images to the site - both directly on the site and via the cataloging app. AuctionMethod recommends that you wait until this issue is fully resolved before attempting to upload images to avoid image loss.

We'll update this page when it's resolved and you will be notified. If you haven't subscribed for the alerts on this page yet, please do so.

FROM AWS:
[10:59 AM PDT] We continue to see elevated error rates and latencies for invokes on API Gateway endpoints in the US-WEST-2 Region. While engineers continue to work towards root cause, we have deployed traffic filters from sources with significant increases in traffic prior to the event. As a result of these traffic filters, we are seeing a reduction in error rates and latencies, but continue to work towards full recovery. Although error rates are improving, we do not yet have an ETA for full recovery. The issue is also affecting API requests to some AWS services, including those listed below. Amazon Connect is experiencing increased failures in handling new calls, chats, and tasks as well as issues with user login in the US-WEST-2 Region. We will continue to provide updates as we progress.

[10:33 AM PDT] We are investigating increased error rates for invokes in the US-WEST-2 Region. We do not yet have a root cause, but are investigating multiple potential root causes in parallel. In addition, we are implementing filters on inbound traffic from a set of sources with recent significant traffic shifts, which may help mitigate the impact. We do not yet have a solid ETA, but will continue to provide updates as we progress.

[10:13 AM PDT] We are investigating increased error rates for invokes in the US-WEST-2 Region.
Posted Sep 28, 2022 - 14:27 EDT
This incident affected: Website (Image Processing).